Decaf trace reader installation program

First of all, there is no configuration file, as mentioned in INSTALL file, inside trace_reader directory. You should not worry about it.

When you run ‘make’ command, sometime compiler raises error for various undefined functions. You should make sure that binutils-multiarch is installed on the system. So, following instruction may help you — at least it worked for me 🙂 :

$ sudo apt-get install binutils-multiarch
$ sudo mv /usr/lib/libbfd.so /usr/lib/libbfd.so.bk
$ sudo mv /usr/lib/libopcodes.so /usr/lib/libopcodes.so.bk
$ sudo ln -s /usr/lib/libbfd-<VERSION-INFO>-multiarch.so /usr/lib/libbfd.so
$ sudo ln -s /usr/lib/libopcodes-<VERSION-INFO>-multiarch.so /usr/lib/libopcodes.so

$ make

Advertisements